最新消息:欢迎加入小松的QQ群一起讨论一起学习,搜索页面修改成lua+ElasticSearch,使用php这个页面速度相对慢一点,优化之后速度杠杠的,如有问题请加群联系我

Linux

lnmp无法删除.user.ini

lnmp无法删除.user.ini

10个月前 (10-02) 303浏览 0评论

在Linux里删除目录的时候发现没有办法删除,最后一个一个文件删除,发现是.user.ini文件的问题删除的是提示rm: cannot remove `.user.ini': Operation not permitted无法删除“.user...

sendmail邮件队列详解

sendmail邮件队列详解

10个月前 (09-23) 204浏览 0评论

sendmail是用来发邮件的,之前小松很多文章里都有提到过,今天这篇文件讲sendmail的知识点可能你不一定留意到①使用sendmail命令发的邮件默认保存在/var/spool/mqueue目录下②邮件消息可能由于很多原因而排入队列,如果一...

centos 32位下安装gitlab

centos 32位下安装gitlab

11个月前 (09-08) 744浏览 1评论

目前系统的环境centos6.4 32位已经安装mysql nginx下载并安装GPG keywget -O /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6 https://www.fedoraproject.org...

解决gem连接失败的问题

解决gem连接失败的问题

11个月前 (09-05) 250浏览 1评论

由于国内网络原因(你懂的),导致 rubygems.org 存放在 Amazon S3 上面的资源文件间歇性连接失败,我是在执行gem install bundler --no-ri --no-rdoc命令的时候发现[root@carson ~...

yum 出现错误File

yum 出现错误File “/usr/bin/yum”, line 30

11个月前 (08-19) 222浏览 0评论

今天用yum在安装ansible的时候,提示有错误百度一下原因这是因为yum采用python作为命令解释器,这可以从/usr/bin/yum文件中第一行#!/usr/bin/python发现。而python版本之间兼容性不太好,使得2.X版...

python 升级亲测

python 升级亲测

11个月前 (08-16) 258浏览 4评论

之前在做利用腾讯cos备份网站的时候,因为python版本不够导致不能使用,腾讯云提供的程序,今天打算升级一下python【wodpress 利用腾讯COS对象存储器进行备份】我使用的是centos,想用yum升级一下,结果没有办法升级,那只能下...

gcc升级日记

gcc升级日记

11个月前 (08-13) 234浏览 0评论

最近要执行一个c++的程序,不是自己写的自己也不会,发现有错误,查了一下要c++11版本,于是决定升级一下gcc,gcc默认带的是gcc4.4.7的老版本,下面开始升级操作wget http://gcc.skazkaforyou.com/relea...

nginx+nginx_mod_rtmp流媒体服务器搭建手记

nginx+nginx_mod_rtmp流媒体服务器搭建手记

12个月前 (08-04) 871浏览 4评论

有一套直播的系统,想跑器来,但是要流媒体服务器,刚开始想到的是是否可以用第三方比如七牛云,但是七牛云流媒体服务器要企业用户才开放,那就自己搭建一个安装依赖包:yum install gcc glibc glibc-devel libtool ma...

编译FAAC-1.28时遇到错误

编译FAAC-1.28时遇到错误

12个月前 (08-01) 303浏览 0评论

编译FAAC-1.28时遇到错误,mpeg4ip.h:126: error: new declaration ‘char* strcasestr(const char*, const char*)’如下图解决方法:vi common/mp4...

利用百度云盘进行网站备份

利用百度云盘进行网站备份

1年前 (2016-07-15) 314浏览 2评论

最近想到一个网站备份的问题,就是如何利用百度云盘进行备份,于是百度一下,发现bpcs_uploader的一个程序可以实现这个功能github下载地址: https://github.com/oott123/bpcs_uploader①应用授权修...