最新消息:欢迎访问小松个人博客,博客已经启用lua+redis防火墙功能,请不用用阿里云ISP机子访问博客

phpmd/PHP_PMD requires package PHP_Depend版本必须大于1.1.1

Linux 47浏览 0评论

phpmd/PHP_PMD requires package PHP_Depend版本必须大于1.1.1

[root@PQDtQc18505 home]# pear install --alldeps phpmd/PHP_PMD
Unknown remote channel: pear.pdepend.org
phpmd/PHP_PMD requires package "channel://pear.pdepend.org/PHP_Depend" (version >= 1.1.1)
No valid packages found
install failed

我在执行pear install –alldeps phpmd/PHP_PMD命令的时候发现错误,大概的意思是 phpmd/PHP_PMD 必须PHP_Depend版本必须大于1.1.1

解决方法

sudo pear channel-discover pear.pdepend.org
pear remote-list -c pdepend
sudo pear install pdepend/PHP_Dep

在执行上面错误的命令就解决了

PHP_PMD安装成功

QQ交流群:136351212(满) 455721967

如无特别说明,本站文章皆为原创,若要转载,务必请注明以下原文信息:
转载保留版权:小松博客» phpmd/PHP_PMD requires package PHP_Depend版本必须大于1.1.1
本文链接地址:https://www.phpsong.com/3399.html

发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
木有头像就木有JJ!点这里按步骤申请Gravatar头像吧!