最新消息:欢迎加入小松的QQ群一起讨论一起学习,本站启用elasticsearch全文检索系统,提供搜索的精确度

laravel怎么解决npm install的问题

PHP 744浏览 0评论

最近在看laravel发现安装Elixir的时候发现了一个问题,项目下
npm install
之后发现有3个包没有安装上

npm WARN EPEERINVALID vueify@5.0.4 requires a peer of babel-runtime@^5.8.25 but none was installed.
npm WARN EPEERINVALID vueify@5.0.4 requires a peer of vue-hot-reload-api@^1.2.0 but none was installed.
npm WARN EPEERINVALID vueify@5.0.4 requires a peer of vueify-insert-css@^1.0.0 but none was installed.

找了一下解决方法,发现网上还没有完整版的解决方法
那我来写一下,执行

npm install vue-hot-reload-api

成功解决一个问题

requires a peer of vue-hot-reload-api

执行

npm install vueify-insert-css

成功解决一个问题

requires a peer of vueify-insert-css

执行

npm install babel-runtime

发现还是有这个错误

requires a peer of babel-runtime

怎么解决这个问题呢
打开项目下的package.json的文件,在dependencies项里添加

"babel-runtime": "^5.8.34"

在执行npm update就成功了
后来我发现,是babel-runtime的版本问题,把上面的版本修改成6.3.19就会有这个问题

requires a peer of babel-runtime版本问题

QQ交流群:136351212

如无特别说明,本站文章皆为原创,若要转载,务必请注明以下原文信息:
转载保留版权:小松博客» laravel怎么解决npm install的问题
本文链接地址:https://www.phpsong.com/1971.html

fasd 发表我的评论   换个身份
取消评论
表情
木有头像就木有JJ!点这里按步骤申请Gravatar头像吧!